Results 1 to 4 of 4

Thread: FSPassengersX Help

  1. #1

    Default FSPassengersX Help

    Hey,

    I have recently downloaded FSPassengersX and I installed it. Finally, when I open FSX it says "your version of FSX is outdated, you need at least SP1 or SP2 installed. So, I downloaded SP1 and SP2, I installed SP1 and its said "You have succesfully installed SP1", So, I started FSX and it said "Your version is outdated...etc...". Then I tried to install SP2 and it says "Cannot install SP2 because SP1 is not installed" ???

    Please answer ASAP Thanx,

    ~Rokie90~

  2. #2
    Join Date
    Oct 2006
    Location
    Edenvale Johannesburg South Africa
    Posts
    173

    Default

    Rokie90, sorry to ask the question, but is your FSX base legal. This normally happens if the base FSX is not legal.

    Try Uninstalling, a big ask if you have a lot of add-ons, use a good quality registry cleaner, such as Piriform CCleaner, or Macecraft Powertools (the best), and then re-install.
    Screwbottle

    Windows 7 Ult. x64 / Ubuntu 13.04 Raring Ringtail / Intel Core2 Duo 6850 3GHZ CPU / MSI X-38 Diamond mobo / Asus ATI EAH5770 CUcore 1GB PCIe video / 6GB DDR3 1333MHZ / Onboard Realtek 7.1 Surround / 500GB Winboot, 2TB Data, 500GB Linuxboot SATAIII / Dualboot system / 18x SATA DVDRW * 2 Opticals / Thermaltake Toughpower 750W / Zalman CNPS9700 LED Cooler

  3. #3

    Default

    Yup it is legal i bought it, ill try doing what you said and i will reply..

    PS. I changed laptops so its still clean

  4. #4

    Default

    Lol sorry for the very very late replay but it works on my new laptop now.

    Thanx,
    ~Rokie90~

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •